How to archive emails addressed to mail-enabled public folders

Problem:

Emails addressed to a mail-enabled public folder are not being archived by Exclaimer Mail Archiver.


Environment:

  • Exclaimer Mail Archiver
  • All supported environments

Cause:

By default, Microsoft Exchange server does not journal emails which are addressed to public folders.


Solution:

Exclaimer Mail Archiver can archive emails addressed to mail-enabled public folders. Steps required to do this are summarized below:

  1. Create a new user with a mailbox.
  2. Forward all posts addressed to the mail-enabled public folder to the user created in step 1.
  3. Set the appropriate access permissions for users to be able to see archived emails for the public folder.
  4. From the Exclaimer Mail Archiver console, navigate to Mail Archiver > Storage > {Your Archive Store Name} and select the Security tab. Here, configure each user to be able to search for emails addressed to the public folder email address, as shown in the example below:

  5. Configure each user in Exclaimer Mail Archiver

For information about forwarding emails addressed to a mail-enabled public folder to the user created above, click here.


Forwarding emails addressed to a mail-enabled public folder to a user

The procedure required to forward all emails addressed to a mail-enabled public folder to a user is described below, for different operating systems:


Microsoft Exchange 2013

  • Open the Exchange Admin Center.
  • Navigate to public folders.
  • Click on the mail-enabled public folder that you wish to archive to highlight it, then click the Edit button.
  • Click Delivery Options.
  • Enable the Forward to: feature, and choose the user created previously.

Microsoft Exchange 2010 / 2007

  1. Open the Microsoft Exchange Management Console.
  2. In the console tree, click Toolbox.
  3. In the result pane, click Public Folder Management Console, then in the action pane, click Open Tool. The Public Folder Management Console is displayed.
  4. In the public folder tree, right-click on the mail-enabled public folder that you wish to archive and select Properties.
  5. Under Mail Flow Settings, select Delivery Options and then Properties...
  6. In the Delivery Options window, enable the Forward to feature and enter the email address of the user created previously.

Microsoft Exchange 2003

  1. Open the Microsoft Exchange System Manager.
  2. In the console tree, expand Folders and then Public Folders.
  3. Right-click on the mail-enabled public folder and select Properties.
  4. Under the Exchange General tab, click Delivery Options.
  5. In the Delivery Options window, enable the Forward to feature and select the email address of the user created previously.