Using the "Update Outlook Web Access signature & settings from server" option fails in specific environments

Symptoms

Using the "Update Outlook Web Access signature & settings from server" option when Signature Manager software is installed in an Exchange 2007 environment fails. The Application Event Log shows an entry "Failure to update OWA signature (0x8004011d) for CN=Username,CN=Users,DC=networkname" for each user in your organization.

Cause

This error is caused when all of the following conditions are met:
  • The mailbox server is running Microsoft Exchange 2007.
  • Microsoft Exchange Server MAPI Client and Collaboration Data Objects is used as the MAPI client on the computer with Signature Manager installed (available from Microsoft here).
  • You answered "No" to the question "Do you have any client computers running Outlook 2003 and earlier or Entourage in your organization?" during the installation of Exchange 2007, or legacy-support has been disabled in Microsoft Exchange post-installation.

Resolution

Uninstall the Microsoft Exchange Server MAPI Client and Collaboration Data Objects package from the computer with Signature Manager. Reboot the computer and install Microsoft Outlook 2007 or Microsoft Outlook 2010 32-bit on the computer.